Recent Changes?

Get help. Get answers. Let others lend you a hand.

Moderator: Mr_Noodle

Recent Changes? Sat Nov 02, 2019 8:44 am • by sn00m
Hello,

Has there been any significant changes to the way Hazel processes rules because somewhere in the last few releases, my rules which had been working perfectly have suddenly stopped working correctly.

Can I get some help please?
sn00m
 
Posts: 9
Joined: Fri Dec 22, 2017 8:17 pm

Re: Recent Changes? Mon Nov 04, 2019 11:32 am • by Mr_Noodle
Try the troubleshooting guide here: https://www.noodlesoft.com/kb/hazel-tro ... ing-guide/

Report back with the results of each step.
Mr_Noodle
Site Admin
 
Posts: 8197
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Re: Recent Changes? Wed Nov 06, 2019 9:50 am • by sn00m
It was a while back but I originally got some help back in 2017:

viewtopic.php?f=4&t=9264#p24642

The fix back then was to change my nested folder rule and simplify it - This is what seems to have broken:

THIS SUGGESTED RULE NO LONGER WORKS:

If .. ALL .. of the following..
SUBFOLDER DEPTH .. IS GREATER THAN .. 1 ..
Do the following..
MOVE .. to folder .. ENCLOSING FOLDER.

Did something change in Hazel to make the above rule no longer function? Weird how it worked and all of a sudden just stopped? Instead of working as expected it just kicks out some random files from the folder. ???

PS: It would be so much easier if we could just attach screenshots to this forum!
sn00m
 
Posts: 9
Joined: Fri Dec 22, 2017 8:17 pm

Re: Recent Changes? Wed Nov 06, 2019 10:23 am • by Mr_Noodle
Again, I suggest using the troubleshooting guide. Please report back with how it looks in the preview, rule status and logs.
Mr_Noodle
Site Admin
 
Posts: 8197
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Re: Recent Changes? Sun Nov 17, 2019 9:57 am • by sn00m
Mr_Noodle wrote:Again, I suggest using the troubleshooting guide. Please report back with how it looks in the preview, rule status and logs.


Hello Mr. Noodle -- Thanks for checking-in. I have run through the troubleshooting and run some previews and other tests as suggested. From what I can tell, the problem revolves around Hazel acting upon a folder before all its files are done copying, therefore the rules get all muddled up.

Is there a way to force hazel to not act upon a (nested) folder until copying (also via a seperate hazel rule) is complete? Finally, does this scenario jive with any recent changes because as I said initially, this all worked swimmingly up until a few months ago?

Cheers!
sn00m
 
Posts: 9
Joined: Fri Dec 22, 2017 8:17 pm

Re: Recent Changes? Mon Nov 18, 2019 12:10 pm • by Mr_Noodle
What program is doing the copying?
Mr_Noodle
Site Admin
 
Posts: 8197
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Re: Recent Changes? Mon Nov 18, 2019 8:05 pm • by sn00m
Mr_Noodle wrote:What program is doing the copying?


Hazel is. I have three rules copying files on Folders A, B and C to copy files to a Working Folder. Then from there, I have eight rules on the Working Folder that work on the files, ie: copy standalone files, flatten folders, unarchive RARs, delete chaff, etc.

What I discovered was that if I pause all the rules on the Working Folder, and let Hazel do the copying from Folders A, B and C (letting them fully copy to the Working Folder) I can then manually unpause the rules on the Working Folder and the rules then work as intended.

If I don't do this, I get weird results - For some files/folders it works fine, for others I am left with a single random part RAR file or nothing at all.

The oddest thing, is that it was all working fine up until a few updates ago.

Thanks again for taking the time!
sn00m
 
Posts: 9
Joined: Fri Dec 22, 2017 8:17 pm

Re: Recent Changes? Tue Nov 19, 2019 10:52 am • by Mr_Noodle
Are you copying multipart RARs and having Hazel on the other end unarchiving them? In that case, Hazel can't know when all the parts are there.
Mr_Noodle
Site Admin
 
Posts: 8197
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Re: Recent Changes? Wed Nov 20, 2019 2:16 am • by sn00m
Mr_Noodle wrote:Are you copying multipart RARs and having Hazel on the other end unarchiving them? In that case, Hazel can't know when all the parts are there.


Hmm.. Exactly this. And while it makes sense, I can't fathom why it suddenly stopped working? I might try adding the suggestion from this post as a fix: https://www.noodlesoft.com/forums/viewtopic.php?f=3&t=9689

Or is there an internal way for Hazel to wait?

EDIT: Actually I might try having Hazel add a new tag "Ready" after it has copied the folder and then only allow my rules to process folders if this "Ready" tag is visible. I've tested the copying/tagging rule and the tag is applied after the folder is fully copied so I think this should work, I think?
sn00m
 
Posts: 9
Joined: Fri Dec 22, 2017 8:17 pm

Re: Recent Changes? Wed Nov 20, 2019 11:26 am • by Mr_Noodle
If the tag works, then by all means.
Mr_Noodle
Site Admin
 
Posts: 8197
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City


Return to Support