What are Hazel’s system requirements?

  Back to search results

Hazel runs on a Mac running macOS 10.10 or higher.

If you need to run an older version of Hazel for previous operating systems, you can find them here.