Please read if you are experiencing hangs on Catalina

The latest noodlings

Moderator: Mr_Noodle

You can put them up on a Cloud sharing service. Many have ways of only allowing people you send the link to to access it.
Site Admin
Posts: 8517
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

I am experiencing the problem constantly and can recreate it at will by creating a new rule or matching a rule. I have a log but cant seem to attach it. I am not sure what I am doing wrong.

Mr_Noodle wrote:If you are experiencing hangs with System Preferences/Hazel on Catalina, and are willing to help diagnose the issue, please help. I am trying to work with Apple to track down the issue but there seems to be a lack of info.

First off, if you can replicate it on demand, please post here with the steps taken.

In addition:

1. Reproduce the problem or wait for the problem to happen again. If an error message appears, leave the error dialog on screen.
2. Capture a screenshot. (The timestamp will show us where in the logs in to look.)
3. As soon as you see the problem happening, hit Shift-Cmd-Ctrl-Opt-period to trigger the sysdiagnose. The screen should flash to indicate it has started.
4. When it is done, Finder will open a window to the location of the log file in /var/tmp/. Attach that file back to us, as well as the screenshot that you took.

Please also capture a System Profile information report from About This Mac and attach that back as well.

Note that I will be forwarding this info to Apple so please keep that in mind.
Posts: 1
Joined: Thu Dec 15, 2016 8:34 pm

I have written a couple of rules utilising a green tag. Previews ran okay. I moved to the Trash tab and attempted to check the 'Delete files...' checkbox. I think I noticed then that Hazel or the System Preferences had hung. Clicking on the red close button on System Preferences did nothing. I tried to quit it using the dock icon with no effect. I went to the Apple menu (top left of screen) but couldn't activate it at all. I could close and open Hazel from the menu bar although I don't know if it had any effect. Safari was still working so I went to Noodlesoft support page and found your post. I activated the 'sysdiagnose' file (you should indicate that it takes a few minutes to process) and took a screenshot. Nothing happened so I tried to close macOS via the keyboard power button. Nothing happened until the sysdiagnose file finished its work. The system then asked me if I wanted to switch off. I declined, thinking that maybe I could close System Preferences but I couldn't. I then started to compose this reply, and during writing it, System Preferences woke up again and I was able to close it. Timescale about 5 minutes.

I'm new to this forum and I'm not sure how to upload files to you. Please let me know if it is required.
Posts: 1
Joined: Wed Apr 29, 2020 6:57 am

Please email them in to support. Click the "Contact support" button in Hazel's "Info" section.
Site Admin
Posts: 8517
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Running 10.15.4

Been getting many System Pref hangs over last several months requiring force quitting. Came looking here today because I got a hang yesterday and decided to wait it out overnight. This morning I got a dialog saying system has run out of memory. The force quit dialog showed System Prefs using 263 GBs of memory. Hazel is the only extension added. Force quitting System Prefs restored operations.

Poking around in the Console I got a cluster of "JetsamEvent-2020-05-03-230519.diag" events saying System Prefs is largest user.

Here is a portion from near the top of the report:

"crashReporterKey" : "71835486-E85D-0995-4DF6-28869B7E9A5E",
"kernel" : "Darwin Kernel Version 19.4.0: Wed Mar 4 22:28:40 PST 2020; root:xnu-6153.101.6~15\/RELEASE_X86_64",
"product" : "iMac17,1",
"incident" : "252BB824-D581-47BF-940C-BDFC81424C37",
"date" : "2020-05-03 23:05:19.54 -0400",
"build" : "Mac OS X 10.15.4 (19E287)",
"timeDelta" : 3,
"memoryStatus" : {
"compressorSize" : 73233,
"compressions" : 75310887,
"decompressions" : 7768957,
"zoneMapCap" : 12884901888,
"largestZone" : "vm pages array",
"largestZoneSize" : 457179136,
"pageSize" : 4096,
"uncompressed" : 65766693,
"zoneMapSize" : 1725259776,
"memoryPages" : {
"active" : 3640469,
"throttled" : 0,
"fileBacked" : 758332,
"wired" : 1029589,
"anonymous" : 6521943,
"purgeable" : 47120,
"inactive" : 3634554,
"free" : 9563,
"speculative" : 5252
"largestProcess" : "System Preferences",
"genCounter" : 1,
"processes" : [
"uuid" : "778891a1-0cd6-38ea-a103-a7dd63ecde94",
"states" : [

"age" : 50678478531199,
"purgeable" : 0,
"fds" : 50,
"coalition" : 452,
"rpages" : 2474,
"priority" : 0,
"pid" : 6082,
"cpuTime" : 0.053968000000000002,
"name" : "MTLCompilerService",
"lifetimeMax" : 2569
"uuid" : "ee2b1b7c-59d6-346d-8271-4e25e73d8563",
"states" : [

"lifetimeMax" : 901,
"age" : 205580392581882,
"purgeable" : 0,
"fds" : 50,
"coalition" : 174,
"rpages" : 884,
"priority" : 0,
"pid" : 241,
"idleDelta" : 1399038516042,
"name" : "AudioComponentRegistrar",
"cpuTime" : 0.055076
"uuid" : "bb770492-0430-329c-9522-66b8cb58eee5",
"states" : [

I have rules for only three folders as I'm rebuilding after a clean install which I did to see what may be hanging the system.

I have two rules for two folders. One moves any file from the Desktop to another folder called VDesktop and another does the same for the Downloads folder.

The one that moved the Desktop files has a 1 minute delay "Date last mod is not in the last 1 min. AND Ext. is not download" to keep from moving partially downloaded files.

Also of note is that the Downloads rule had a note attached about I think changing a tag to blue AND I could not remove the note which I thought odd so I deleted the rule and recreated it. The original folder had the downloads folder image icon and the recreated one had a generic folder icon.

The third and last folder has 10 rules. All but one are content matches and one is a content match plus a name contains match.

Now that I see Hazel's possible involvement I'll follow your steps to capture and sent data to you going forward.
Posts: 5
Joined: Sat Jun 18, 2016 5:07 am

I have a replicable hang using Hazel too. Steps:

1 Open Hazel
2 Select add
3 create rule
4 save rule
5 attempt to close Hazel
6 open Force Quit
7 select System Preferences, no notification of not responding
8 relaunch System Preferences

Hope this helps.
Posts: 1
Joined: Sat Feb 23, 2019 1:09 am


Return to Announcements