Multi Copy Items not working

Get help. Get answers. Let others lend you a hand.

Moderator: Mr_Noodle

Multi Copy Items not working Sat Jul 06, 2019 10:25 am • by dealtek
I created a folder rule to copy items.

The problem is that only the top destination is successfully copied to. The bottom two destinations get ignored. I can drag anyone of the three destinations to the top and that will work and the other to get ignored.

Question: how can I get all three destinations to work?

--------

I tried this:

One step
if date added is not in the last two minutes

Copy to folder 1
Copy to folder 2
Copy to folder 3

---------------------

Then I tried this - Three separate steps:

if date added is not in the last 1 minutes
copy to folder 1

if date added is not in the last 2 minutes
copy to folder 2

if date added is not in the last 3 minutes
copy to folder 3
dealtek
 
Posts: 10
Joined: Mon Jan 21, 2019 2:15 pm

Re: Multi Copy Items not working Mon Jul 08, 2019 11:05 am • by Mr_Noodle
Note that using multiple copies in the same rule will work differently that what you expect. Any actions after a copy will operate on the copy, not the original. It shouldn't matter in this case but something to keep in mind.

The second version won't work unless you put a "Continue" action in each rule. Otherwise, only the first rule will get matched and run.

I suspect there's an error occurring during the subsequent copies in the first version of your rule. Check the logs and see if you can find it there.
Mr_Noodle
Site Admin
 
Posts: 8110
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Re: Multi Copy Items not working Mon Jul 08, 2019 1:01 pm • by dealtek
THANKS SO MUCH - IT WORKS!!!

I tried: The second version won't work unless you put a "Continue" action in each rule. Otherwise, only the first rule will get matched and run.

Now it all works.

I'll check the logs for issues and let you know if I see anything helpful ...
dealtek
 
Posts: 10
Joined: Mon Jan 21, 2019 2:15 pm


Return to Support

cron