Permissions required for each step of Hazel rules

Get help. Get answers. Let others lend you a hand.

Moderator: Mr_Noodle

Seems like since 10.13, every time I run my Hazel rules (renaming files and FTPing them), I have to enter my password for each step. Before, I might have needed to enter them once for a new rule, but then never again.

Am I crazy?
CMD Z
 
Posts: 2
Joined: Mon May 07, 2018 7:03 pm

First off, please don't post Hazel questions in the Forum/Site Discussion forum. That forum is for issues regarding this site and the forum itself.

I assume you are using Hazel's Upload action? Try resetting the FTP destination in your rule to see if that fixes things.
Mr_Noodle
Site Admin
 
Posts: 8295
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Strange. I have 14 Folders that use a shell script to rename the files, then upload them to a mirrored directory structure on an FTP server. All of them include a "Start Path:" prefix of "/var/www/" in the "[Upload] to server:[server_url]" settings. This is not correct for my server and clicking the "Connect" button returns an error. Removing the prefix allows me to connect and "Open" (select) the appropriate directory, as is expected. The permissions prompt no longer appears.

However, if I go back to check the "Start Path" again, the prefix reappears.

To clarify, I change this:
/var/www/html/my_sample_directory
to:
html/my_sample_directory
...and Hazel changes it back to:
/var/www/html/my_sample_directory

---
Apologies for my poor forum etiquette. Thank you for moving this post to the appropriate section.
CMD Z
 
Posts: 2
Joined: Mon May 07, 2018 7:03 pm

It might be that /var/www is the home directory for the account you are logging in as. So, any path you enter will be added onto that so specifying it as the prefix will end up adding an extra /var/www to the path.
Mr_Noodle
Site Admin
 
Posts: 8295
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City


Return to Support