Date last matched not working

Get help. Get answers. Let others lend you a hand.

Moderator: Mr_Noodle

Date last matched not working Thu May 26, 2016 12:42 am • by invictus26
I have a rule that I only want to apply once to each file, so I added the condition "Date Last Matched - is blank", but even though the rule matches a file and performs its action on it, the preview still shows that Date Last Matched is blank. Am I maybe just not understanding what that condition is for?
invictus26
 
Posts: 16
Joined: Mon Feb 09, 2009 6:15 pm

Re: Date last matched not working Thu May 26, 2016 9:49 am • by Mr_Noodle
Not sure why it remains blank but by default, Hazel does not run the actions again on a file if it matches the same rule over and over. You can try "Date added is after date last matched" as further insurance.
Mr_Noodle
Site Admin
 
Posts: 7968
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Re: Date last matched not working Sun Jan 13, 2019 3:11 pm • by proactivematter
I'm suddenly having this problem also.

I have 2 rules. Both have "Date Last Matched / is Blank" and " Date Added / is After / Date Last Matched", such that if rule 1 runs, rule 2 is not supposed to run.

But I checked with preview and it is in fact rule 1 that is not writing to "Date last matched". Date last matched is only altered after rule 2 runs.

I've tried re-creating creating rule 1 from scratch, but no success...
proactivematter
 
Posts: 4
Joined: Mon Jan 07, 2019 7:03 pm

Re: Date last matched not working Mon Jan 14, 2019 11:38 am • by Mr_Noodle
Can you check the logs? I'm wondering if an error is occurring (thus preventing the date last matched from being filled in).
Mr_Noodle
Site Admin
 
Posts: 7968
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City


Return to Support