Error importing to iTunes

Get help. Get answers. Let others lend you a hand.

Moderator: Mr_Noodle

Error importing to iTunes Sun Nov 26, 2006 12:00 am • by stewf
I have a rule to import any file with the extension "mp3" to iTunes. The files match, but Hazel is not doin'. Here is the error in Console:

Code: Select all
2006-11-25 19:57:57.796 hazelfolderwatch[3086] 75523971ef010fc6.mp3: Rule MP3s to iTunes matched.
2006-11-25 19:57:57.855 hazelfolderwatch[3086] Error adding file 75523971ef010fc6.mp3 to itunes: {
    NSAppleScriptErrorMessage = "iTunes got an error: alias \"StewfBook:Users:stewf:Downloads:75523971ef010fc6.mp3\" doesn't understand the add message.";


The very same MP3 files import fine when I do it manually by dragging them to the iTunes window.

I am using OS X 10.4.8 and iTunes 7.0.2
stewf
 
Posts: 4
Joined: Sat Nov 25, 2006 11:53 pm

Sun Nov 26, 2006 3:07 pm • by Mr_Noodle
Hmm, not sure what is going on here. Is this happening for all mp3's or just certain ones? Also, how are the files being put into that folder? Are they being downloaded by a browser and if so, which one?

Also, let me know if you are willing to send me a file that exhibits this problem.

Thanks.
Mr_Noodle
Site Admin
 
Posts: 8415
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Sun Nov 26, 2006 8:59 pm • by stewf
It seems to be failing on any MP3 file. They are being downloaded from NetNewsWire or manually dropped in the folder.
stewf
 
Posts: 4
Joined: Sat Nov 25, 2006 11:53 pm

Mon Nov 27, 2006 3:10 pm • by Mr_Noodle
I'll see if I can replicate things using NetNewsWire. My original theory was that the import was happening before the file had completed downloading but if you say that it also happens when you drop a file into the folder, then it is less likely to be the case.

I'll poke around some more but definitely let me know if anything else turns up.
Mr_Noodle
Site Admin
 
Posts: 8415
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Mon Nov 27, 2006 4:07 pm • by Mr_Noodle
Actually, I think I found something.

Are you running under a non-English language or have you renamed your iTunes library? If so, would you be willing to run a script for me on your end?

Thanks.
Mr_Noodle
Site Admin
 
Posts: 8415
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Mon Nov 27, 2006 4:10 pm • by stewf
Ah yes, I have changed my library name. Should I change it to the default or take your script?
stewf
 
Posts: 4
Joined: Sat Nov 25, 2006 11:53 pm

Mon Nov 27, 2006 4:14 pm • by Mr_Noodle
You shouldn't have to change it. I need to fix it on my end.

If you are willing, I can send you an Applescript to try out. You can hook it up in Hazel by using the "Run Applescript" action. Once I can confirm it working, I'll get it in the next maintenance release (which should be going out sometime in the next week or so).

Could you send me an email (http://www.noodlesoft.com/support.html)? I can send you the applescript then.

Thanks.
Mr_Noodle
Site Admin
 
Posts: 8415
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City


Return to Support