.dmg issue?

Get help. Get answers. Let others lend you a hand.

Moderator: Mr_Noodle

.dmg issue? Mon Sep 11, 2006 11:12 pm • by bluloo
Hi,

I saw Hazel today and am quit excited about the application's potential.

I have a rule set up, as suggested in your tips and tricks to change the label color to gray if the date last opened is after than the date added.

As a test I opened a gif. It was promptly labeled grey within a few seconds. I then opened a.dmg file and ejected the image. The original file was not labeled.

I didn't modify the gif and the label color was applied, as expected. No go for the .dmg.

I use the grey label as a visual to note that I installed software and much of it is in .dmg format.

There is only one rule set up at present and both the gif and dmg are in the same directory.

Any suggestions?

thanks
bluloo
 
Posts: 10
Joined: Mon Sep 11, 2006 10:46 pm

Tue Sep 12, 2006 10:23 am • by Mr_Noodle
Unfortunately, updates to things such as the date attributes do not trigger Hazel right away so it may take a couplle minutes before the change is seen. If after a few minutes it is not coloring the dmg file then something else is happening.

Are you running 1.0.2? If so, in Console.app you can check the logs to see if it matched the rule at all.

Another thing I just thought of: did you open the disk image immediately when it showed up? There's a chance that you opened it before Hazel could record the date added (so the date added ends up later than the date last opened). A long shot but I thought I'd bring it up.
Mr_Noodle
Site Admin
 
Posts: 8427
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Tue Sep 12, 2006 11:36 am • by bluloo
Yes, I am running v 1.02. Hazel is not recording the mounting of a disk image as a "change".

Here is the brief console log when I mounted a disk image adn then trashed the file in the mounted image this morning. Hazel was installed and the rule enabled last night.

The image is "quartz simple" and it is in the "applications" subdirectory.

I have a rule set up in Hazel as described previously.

2006-09-12 11:28:09.791 hazelfolderwatch[1854] Could not switch to directory: </Volumes/QuartzSimple/.Trashes/501>
Sep 12 11:28:15 MacPro diskarbitrationd[44]: hazelfolderwatch [1854]:24779 not responding.
2006-09-12 11:28:16.028 hazelfolderwatch[1854] Watch paths have changed. Spawning process to fix.
2006-09-12 11:28:16.047 hazeljobfix[1858] Launchd watchpaths out of sync. Redeploying.
2006-09-12 11:28:16.093 hazeljobfix[1858] Watcher successfully redeployed for paths: ("/Users/Louis/.Trash")
2006-09-12 11:28:21.852 hazelfolderwatch[1861] Processing directories: ("/Volumes/Backup/Downloads")


Next, I opened a zip folder in the same directory and Hazel caught it , as expected. See the console log below:

2006-09-12 11:29:39.860 hazelfolderwatch[1862] Processing directories: ("/Volumes/Backup/Downloads/Applications")
2006-09-12 11:31:51.020 hazelfolderwatch[1868] Processing directories: ("/Volumes/Backup/Downloads/Applications")
2006-09-12 11:31:51.220 hazelfolderwatch[1868] WriteInOne.zip: Rule Installed matched.

Something is up with the .dmg file handling.
bluloo
 
Posts: 10
Joined: Mon Sep 11, 2006 10:46 pm

Tue Sep 12, 2006 1:37 pm • by Mr_Noodle
Here's something you could try. It involves delving into Hazel's data files so if you are uncomfortable with this then let me know.

- Go to ~/Library/Application Support/Hazel. In there you will see XXX.hazeldb files (one for each folder monitored). Unfortunately, they have names which are not obvious (except for trash) but look for the dmg file name in them (you can view them in TextEdit).
- Checked the date added field for the file.
- Compare it to the date accessed for the file (you can get it from "Get Info" in the Finder).

Let me know if this turns up anything.
Mr_Noodle
Site Admin
 
Posts: 8427
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Tue Sep 12, 2006 3:27 pm • by bluloo
You are a genius.

I am using PathFinder as well as the Finder.
The last opened date wasn't being recorded/changed when quick image mounting was selected in PF's preferences. Deselecting that pref seems to allow the attribute to update properly and Hazel now applies the proper label.

You have another convert. :)

Thank you for the help. I'm going to submit this as a bug to the Cocoatech people as well.


:)
bluloo
 
Posts: 10
Joined: Mon Sep 11, 2006 10:46 pm

Tue Sep 12, 2006 5:20 pm • by Mr_Noodle
Always happy to pawn a bug off on somebody else. :D
Mr_Noodle
Site Admin
 
Posts: 8427
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City


Return to Support