Contain Match Date matching random date not in document

Get help. Get answers. Let others lend you a hand.

Moderator: Mr_Noodle

I have a hazel rule that takes one of my bills, takes out the due date, and uses that to help name the file, tag it, and sort it into a folder. I do this on majority of my bills and don't have this issue but for one right now it seems to read the file, match the date, but then just selects April 30th, 2019 arbitrary as the date. This date does not appear in any of these documents and when I look through a preview it highlights the correct date but then parses it to the April 30th, 2019 date.

This is how the rule is set
Image

This is how I have date detection set up
Image

This is what that date detection displays in a preview file
Image

This is what it actually detects
Image

Why is it finding the correct date in the document but when it converts it to its date format for later use its just gets April 30th, 2019? The other weird thing about this rule which I have recreated from scratch is it seems to work at first but after time or a restart it does this.
bbech
 
Posts: 4
Joined: Mon Mar 02, 2020 11:10 pm

Do you have a sample file, without any personal info, that you can email in? If so, send it in along with an export of your rule(s).
Mr_Noodle
Site Admin
 
Posts: 8522
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Mr_Noodle wrote:Do you have a sample file, without any personal info, that you can email in? If so, send it in along with an export of your rule(s).


Is there a way to find deleted rules? I messed with it more after submitting this and it seems to be working correctly. Not really sure what was different because I set it up exactly the same. I may do a reboot to see if the issue still occurs
bbech
 
Posts: 4
Joined: Mon Mar 02, 2020 11:10 pm

Do you keep backups? If so, you can get it from there. Otherwise, I'll consider it a fluke occurrence.
Mr_Noodle
Site Admin
 
Posts: 8522
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Mr_Noodle wrote:Do you keep backups? If so, you can get it from there. Otherwise, I'll consider it a fluke occurrence.


Unfortunately my time machine drive died a couple weeks ago and I haven’t got a new one. I realized I shouldn’t of deleted the minute I deleted it but I was just happy to get it working.
bbech
 
Posts: 4
Joined: Mon Mar 02, 2020 11:10 pm

Well, if it happens again, send in the files as I'd be very curious as to what was going on there. Thanks.
Mr_Noodle
Site Admin
 
Posts: 8522
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Mr_Noodle wrote:Well, if it happens again, send in the files as I'd be very curious as to what was going on there. Thanks.


So I found out that in all this trying to figure out the issue I actually had multiple copies of the rule in my list. I may try and figure out how to remove my PII from the bills and send everything over for you to trouble shoot.
bbech
 
Posts: 4
Joined: Mon Mar 02, 2020 11:10 pm


Return to Support