Please read if you are experiencing hangs on Catalina

Get help. Get answers. Let others lend you a hand.

Moderator: Mr_Noodle

If you are experiencing hangs with System Preferences/Hazel on Catalina, and are willing to help diagnose the issue, please help. I am trying to work with Apple to track down the issue but there seems to be a lack of info.

First off, if you can replicate it on demand, please post here with the steps taken.

In addition:

1. Reproduce the problem or wait for the problem to happen again. If an error message appears, leave the error dialog on screen.
2. Capture a screenshot. (The timestamp will show us where in the logs in to look.)
3. As soon as you see the problem happening, hit Shift-Cmd-Ctrl-Opt-period to trigger the sysdiagnose. The screen should flash to indicate it has started.
4. When it is done, Finder will open a window to the location of the log file in /var/tmp/. Attach that file back to us, as well as the screenshot that you took.

Please also capture a System Profile information report from About This Mac and attach that back as well.

Note that I will be forwarding this info to Apple so please keep that in mind.
Mr_Noodle
Site Admin
 
Posts: 8575
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

I am getting hangs. It hasn’t done it a while so I thought it was fixed. Unfortunately it did it again today. I can’t recreate on demand and it doesn’t happen all the time so I suspect it’s conflicting with something else. Just not sure what.
MarkLewis
 
Posts: 1
Joined: Mon Oct 21, 2019 1:05 pm

If you can provide the diagnostics listed above that would be great. I'm forwarding it to Apple so that they can get a handle on it. I've had actually very little sent to me so far so it's been slow going.
Mr_Noodle
Site Admin
 
Posts: 8575
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

I seem to be getting reliable hangs, requiring me to force quit System Preferences in order to regain control.

I experienced it twice today, each time when I duplicated an existing rule and edited it. This rule was date based, so all I was doing was changing the year of the date to 2020 and selecting a new folder to receive the matching items (they are moved).

I will submit the sysdiagnose log, system profile, and time stamp via email.

Hope you can sort this out, as these hangs make it difficult to use Hazel.
margaretamartin
 
Posts: 1
Joined: Mon Mar 09, 2020 12:57 pm

Should we send these to the support email?
bmxdarcy
 
Posts: 1
Joined: Sat Mar 14, 2020 11:09 am

Yes, though, for the moment, I suggest holding off. The exception is if you are running the latest Catalina beta (10.15.4), in which case, then please send those in.
Mr_Noodle
Site Admin
 
Posts: 8575
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

I can reproduce easily with Catalina 10.15.4 (19E258a)

System Preferences
Hazel
Create a new rule that moves everything older than a week from downloads to a dropbox folder
click the eye icon(show rule status)

Crashes almost every time.
I have also send a support email with requested info

Travis
travisll
 
Posts: 1
Joined: Thu Dec 08, 2011 10:37 pm

I'm repeatedly getting hangs in Catalina 10.15.3, trying to import rules into Hazel on my new Mac. I have a series of folders that all have the same simple rule applied (sort into subfolder by year file was created). Hazel hangs (and one CPU core goes to 100%) after I've imported between 3-5 of these rules, without even making them active.

I need to force quit System Preferences, relaunch Hazel and I can add 3-5 more, and the process repeats.
TheRFMan
 
Posts: 1
Joined: Thu Mar 19, 2020 10:07 am

margaretamartin wrote:I seem to be getting reliable hangs, requiring me to force quit System Preferences in order to regain control.


I do not know if this will help you, but on my computer I now know I can wait out the hang, control returns to me at 3 minutes. At that point i'm able to use Hazel without another hang until I close the app.

My experience is that I'll have the same 3 minute wait the next time I start the app and get the hang, but the app is usable after those 3 minutes.

Warm regards.
jolipoli
 
Posts: 1
Joined: Wed Jul 11, 2012 5:16 pm

Does it happen if you interact with anything pertaining to tags or color labels?
Mr_Noodle
Site Admin
 
Posts: 8575
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

I just upgraded to 10.15.4 (non-beta).
When I click on the Hazel icon in the System Preferences, a dialog pops up that says Preferences Error, Could not load Hazel preferences pane.

The Hazel icon and menu are still in the menu bar.
mudskip
 
Posts: 2
Joined: Sun Mar 29, 2020 11:47 am

That is a different issue. Post a new thread under support with output from the logs when you try and load the pane.
Mr_Noodle
Site Admin
 
Posts: 8575
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Mr_Noodle wrote:That is a different issue. Post a new thread under support with output from the logs when you try and load the pane.


Sorry for replying here, feel free to delete.
Just wanted to say that i checked again some hours later, and the preference pane loaded normally.
I was thinking maybe it was related to the re-indexing that happens sometimes when updating to new version of macOS [just a guess].
mudskip
 
Posts: 2
Joined: Sun Mar 29, 2020 11:47 am

I would like to add a plus one for the issue. I am waiting for the system diagnostic to finish running, and then I will email the requested information. Editing rules most commonly trigger the problem. Almost always, if I edit a rule or two Hazel will hang to the point where I have to restart the computer.
burke57
 
Posts: 4
Joined: Sat Dec 21, 2019 8:41 am

The sysdiagnose file is can be huge (333 MB). How are files loaded here and how are they protected from public access?
Paul99
 
Posts: 1
Joined: Mon Feb 06, 2017 1:55 pm

Next

Return to Support