Debug Mode is automatically turned on...

Get help. Get answers. Let others lend you a hand.

Moderator: Mr_Noodle

Debug Mode is automatically turned on... Mon Jan 14, 2019 8:54 am • by Robert
Is it normal, that the Debug Mode is automatically turned on, or does that mean I have a rule which causes problems?
If I uncheck the Debug-Mode and close the system preferences and re open it, go to Hazel, than the Debug mode is checked again...
"Behind all the inhuman aspects of automation (...) its real possibilities appear: the genesis of a technological world in which man can finally withdraw from (...) the apparatus of his labor – in order to experiment freely with it." /Marcuse
Robert
 
Posts: 27
Joined: Sun Dec 16, 2018 8:05 am

Re: Debug Mode is automatically turned on... Mon Jan 14, 2019 11:42 am • by Mr_Noodle
It shouldn't be. Does it persist after a reboot?
Mr_Noodle
Site Admin
 
Posts: 7633
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Re: Debug Mode is automatically turned on... Mon Jan 14, 2019 8:37 pm • by Robert
Yes it does... even if I stop Hazel before closing the system preferences.
I turned Hazel off > turned the Debug mode off > restarted the mac > opened Hazel and the Debug mode is checked...
strange. I tried it a few times today...
I am running 10.14.2 Mojave.

[Edit: If I go back in the system preferences and leave it open, go to screensaver or anything else and then back to Hazel, the Debug Mode stays off. But again, when I close the system preference window and reopen it, the Debug Mode is On again]
"Behind all the inhuman aspects of automation (...) its real possibilities appear: the genesis of a technological world in which man can finally withdraw from (...) the apparatus of his labor – in order to experiment freely with it." /Marcuse
Robert
 
Posts: 27
Joined: Sun Dec 16, 2018 8:05 am

Looking into it. If you come up with any more details, post them here.
Mr_Noodle
Site Admin
 
Posts: 7633
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Re: Debug Mode is automatically turned on... Wed Jan 16, 2019 8:19 am • by Robert
Until now just that it persists no matter which checkboxes are checked and which ones are not checked under folders, trash and info. And the behavior does not change if I pause all rules or keep them running, nor if hazel is running or not.

Thank You! If I gather any more information I will post it here!
"Behind all the inhuman aspects of automation (...) its real possibilities appear: the genesis of a technological world in which man can finally withdraw from (...) the apparatus of his labor – in order to experiment freely with it." /Marcuse
Robert
 
Posts: 27
Joined: Sun Dec 16, 2018 8:05 am

Re: Debug Mode is automatically turned on... Wed Jan 16, 2019 11:00 am • by Mr_Noodle
I think the issue only happens if you bring up the UI. If you turn it off and do not bring up the UI again, it should stay off. I do have a fix but just something to keep in mind until the fix is out.
Mr_Noodle
Site Admin
 
Posts: 7633
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Re: Debug Mode is automatically turned on... Wed Jan 16, 2019 12:22 pm • by Robert
Thanks for the fast help!
"Behind all the inhuman aspects of automation (...) its real possibilities appear: the genesis of a technological world in which man can finally withdraw from (...) the apparatus of his labor – in order to experiment freely with it." /Marcuse
Robert
 
Posts: 27
Joined: Sun Dec 16, 2018 8:05 am


Return to Support

cron