File Kind mismatch

Get help. Get answers. Let others lend you a hand.

Moderator: Mr_Noodle

File Kind mismatch Sun Nov 19, 2023 9:41 am • by awaldraff
I had to reinstall my computer from scratch. I had saved a large set of rules that manage my .md (markdown) files.

Since the reinstall I noticed Hazel now recognizes the markdown files as "text" files. My rules use kind is "Markdown Documents".

In finder those same files appear as kind: Markdown.

Also: Markdown is not an option in the list of possible file kinds in Hazel. There is "Markdown Document"

My worry is that I have a separate set of rules for text files. So changing the kind statement in the rules is a painful option.

I am running the 53a8 (2355) beta, because I previously had an issue where hazel would not delete empty folders
Posts: 32
Joined: Fri Sep 23, 2016 3:47 pm

Re: File Kind mismatch Mon Nov 20, 2023 9:30 am • by Mr_Noodle
If you set your Markdown rule to appear before the text one, it should be fine, as long as that rule does not use the "Continue" action.
Site Admin
Posts: 11001
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Return to Support