hazelfolderwatch will not run (I think)

Get help. Get answers. Let others lend you a hand.

Moderator: Mr_Noodle

hazelfolderwatch will not run (I think)

Postby speedracer105 » Thu Mar 15, 2007 11:18 am

I keep getting the "Another hazelfolderwatch process..." message. As best as I can tell from using Activity Monitor, top, and ps awx, there is no hazelfolderwatch process running or being run at all. To even get Hazel to work at all, I did the following:

Install Hazel 1.1.5 (play with rules, but Hazel never does anything)
Install Hazel 2.0a1 (still nothing works)
Uninstall Hazel
Install Hazel 1.1.5 (add one rule to color anyfile in Desktop, Works!)
Add the sample rules and enable the New, Not so new, and Old rules (Works!)
Run Rules Now x 3 (Works x 3)
Modify the movies rule to move to ~/Desktop/Movies (change of directory)
Enable Movies rule (Nothing works anymore and now I get the above error)


Note: The .BAHtemp* folder is some sort of RealPlayer temp directory

===== Thursday, March 15, 2007 11:01:33 AM US/Eastern =====
2007-03-15 11:02:56.948 hazelfolderwatch[827] Another hazelfolderwatch process is processing this directory. Exiting.
2007-03-15 11:03:30.292 hazelfolderwatch[828] Another hazelfolderwatch process is processing this directory. Exiting.
2007-03-15 11:05:43.143 hazelfolderwatch[829] Another hazelfolderwatch process is processing this directory. Exiting.
2007-03-15 11:06:04.721 hazelfolderwatch[830] Another hazelfolderwatch process is processing this directory. Exiting.
2007-03-15 11:07:23.142 hazelfolderwatch[831] Another hazelfolderwatch process is processing this directory. Exiting.
2007-03-15 11:08:30.179 hazelfolderwatch[832] Another hazelfolderwatch process is processing this directory. Exiting.
2007-03-15 11:09:13.202 hazelfolderwatch[834] Another hazelfolderwatch process is processing this directory. Exiting.
2007-03-15 11:13:30.296 hazelfolderwatch[841] Lockfile is stale. Updating time and proceeding.
2007-03-15 11:13:32.456 hazelfolderwatch[841] Processing directories: ("/Users/hchapman/Desktop")
2007-03-15 11:13:32.468 hazelfolderwatch[841] Could not retrieve metadata for file: /Users/hchapman/Desktop/.BAHtemp-14245-1804289383
launchd[811]: com.noodlesoft.Hazel.hazelfolderwatch-234881026-293082: exited abnormally: Bus error
launchd[811]: com.noodlesoft.Hazel.hazelfolderwatch-234881026-293082: 9 more failures without living at least 60 seconds will cause job removal
speedracer105
 
Posts: 4
Joined: Thu Mar 15, 2007 10:41 am

Postby Mr_Noodle » Thu Mar 15, 2007 10:44 pm

Yeah, it's crashing trying to access the .BAHtemp* folder and it's doing so before getting to your other files which is why it seems like it's not processing anything.

I'll see if I can get a fix for this in the next alpha.

If you have time could you:
- Do a "mdls" on the .BAHtemp* folder?
- If you have the dev tools installed, do /Developer/Tools/GetFileInfo on it?

Thanks.
Mr_Noodle
Site Admin
 
Posts: 4210
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Postby speedracer105 » Fri Mar 16, 2007 2:33 pm

Mr_Noodle wrote:- Do a "mdls" on the .BAHtemp* folder?
- If you have the dev tools installed, do /Developer/Tools/GetFileInfo on it?


I'll move those .BAHtemp* folders elsewhere, but here's what you requested. There may be other problems on my end since mdls doesn't return any information for any files.


harveybook:~/Desktop hchapman$ mdls .BAHtemp-14245-1804289383/
.BAHtemp-14245-1804289383/ -------------
mdls: could not find .BAHtemp-14245-1804289383/.
harveybook:~/Desktop hchapman$ /Developer/Tools/GetFileInfo .BAHtemp-14245-1804289383/
directory: "/Users/hchapman/Desktop/.BAHtemp-14245-1804289383"
attributes: avbstclinmedz
created: 07/06/2004 17:05:23
modified: 07/06/2004 17:05:23
speedracer105
 
Posts: 4
Joined: Thu Mar 15, 2007 10:41 am

Postby speedracer105 » Fri Mar 16, 2007 2:54 pm

I did a search for the mdls problem and found this fix. One of the commenters, glenn, posted the answer of deleting some system spotlight files, repairing disk permissions, and rebooting. That seemed to do the trick. A FAQ entry about Spotlight requirements might benefit the Hazel website.

Thanks for the help.

One more addendum: I downloaded a movie trailer from apple.com and was trying to test the "Movies" rule. For some reason, the trailer doesn't match. So what constitutes "Kind is Movie?"

My "Movies" rule is enabled and occurs before all others in the list.

hazelfolderwatch[357] harry_potter_phoenix-tlr1_h640w.mov: Rule Newly Added Files matched.

harveybook:~/Desktop hchapman$ mdls harry_potter_phoenix-tlr1_h640w.mov
harry_potter_phoenix-tlr1_h640w.mov -------------
kMDItemAttributeChangeDate = 1970-01-03 09:38:05 -0500
kMDItemFSContentChangeDate = 2007-03-15 10:59:34 -0400
kMDItemFSCreationDate = 2007-03-15 10:57:59 -0400
kMDItemFSCreatorCode = 0
kMDItemFSFinderFlags = 8
kMDItemFSInvisible = 0
kMDItemFSIsExtensionHidden = 0
kMDItemFSLabel = 4
kMDItemFSName = "harry_potter_phoenix-tlr1_h640w.mov"
kMDItemFSNodeCount = 0
kMDItemFSOwnerGroupID = 20
kMDItemFSOwnerUserID = 501
kMDItemFSSize = 8591700
kMDItemFSTypeCode = 0
kMDItemID = 3017752
kMDItemLastUsedDate = 2007-03-15 09:59:34 -0400
kMDItemUsedDates = (2007-03-15 09:59:34 -0400)

harveybook:~/Desktop hchapman$ /Developer/Tools/GetFileInfo harry_potter_phoenix-tlr1_h640w.mov
file: "/Users/hchapman/Desktop/harry_potter_phoenix-tlr1_h640w.mov"
type: ""
creator: ""
attributes: avbstclinmedz
created: 03/15/2007 10:57:59
modified: 03/15/2007 10:59:34
speedracer105
 
Posts: 4
Joined: Thu Mar 15, 2007 10:41 am

Postby Mr_Noodle » Fri Mar 16, 2007 4:42 pm

Yeah, I'll add the Spotlight requirement to the site. Thanks for checking this out.

It appears the movie file has not been imported by Spotlight. My suggestion would be to check to make sure it's not on a drive or in a folder that you set Spotlight to ignore (either via the Spotlight preferences or mdutil). You could try using mdls on other .mov files and see what turns up there as well.
Mr_Noodle
Site Admin
 
Posts: 4210
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City

Postby speedracer105 » Wed Mar 21, 2007 11:52 am

It turns out that Spotlight doesn't automatically index everything anymore (I think it did this when first released). It only indexes files as you access them.
speedracer105
 
Posts: 4
Joined: Thu Mar 15, 2007 10:41 am

Postby Mr_Noodle » Wed Mar 21, 2007 8:36 pm

speedracer105 wrote:It turns out that Spotlight doesn't automatically index everything anymore (I think it did this when first released). It only indexes files as you access them.


Do you have a source for this? This is the first I've heard of it. Was this in a recent update? If this is true, then there's definitely a problem.
Mr_Noodle
Site Admin
 
Posts: 4210
Joined: Sun Sep 03, 2006 1:30 am
Location: New York City


Return to Support

Who is online

Users browsing this forum: No registered users and 4 guests

cron


Copyright © 2006-2012 Noodlesoft, LLC, All Rights Reserved. Mac and the Mac logo are trademarks of Apple Computer, Inc., registered in the U.S. and other countries.